NextGIS Manager

Материал из GIS-Lab
Перейти к: навигация, поиск
Эта страница является черновиком статьи.


Создано в Nextgis.png Веб ГИС для вашей организации по доступной цене

Содержание

Введение

О программе

Программа NextGIS Manager предназначена для управления геопространственными данными (растровыми и векторными). Программа строится по модульному принципу. Все функциональные возможности размещаются в динамических библиотеках, исполняемые файлы лишь вызывают функции из них. Программа может быть гибко настроена редактированием конфигурационных файлов (часть настроек вынесена в специальный диалог настройки). Для наращивания функциональных возможностей достаточно разработать собственную динамическую библиотеку и прописать ее в конфигурационном файле. При разработке программы использовалась библиотека wxWidgets, которая обеспечивает кроссплатформенные возможности. В настоящее время имеется версия под Windows и Linux (конкретнее под Ubuntu). Под Windows программа распространяется, как в виде дистрибутива с установщиком, так и в виде переносимой версии (может запускаться со съемных носителей). Под Ubuntu программа ставиться из репозитория.

Основные возможности

NextGIS Manager предназначен для:

  • просмотра источников геопространственных данных (папок, архивов, растров, векторных файлов и др.) с учетом их форматов
  • просмотра самих геопространственных данных в виде карты или таблицы (в зависимости от типа источника данных, могут быть недоступны некоторые виды)
  • создания источников геопространственных данных (на данный момент поддерживается создание папок в файловой системе, подключений к базам данных, схем в БД)
  • переименования и удаления источников геопространственных данных (файлов в файловой системе, таблиц в БД)
  • копирования и переноса источников геопространственных данных
  • экспорта из формата в формат, поддерживаемых векторных источников геопространственных данных
  • просмотра свойств источников геопространственных данных

В качестве источников геопространственных данных могут выступать:

  • шейп-файлы ГИС ArcGIS (*.shp)
  • таблицы ГИС MapInfo (*.tab, *.mid/*.mif)
  • таблицы DBF
  • файлы обменного формата AutoCad (*.dxf)
  • файлы GoogleEarth (*.kml, *.kmz)
  • файлы GML (*.gml)
  • файлы SXF (*.sxf/*.rsc)
  • растровые файлы (*.bmp, *.jpeg, *.tif, *.gif, *.img, *.png, *.vrt, *.til, *.sdat)
  • веб сервисы WMS, TMS
  • базы данных Postgres/PostGIS

Кроме того, возможно просматривать свойства файлов описания систем координат (*.prj, *.spr, *.qpj).

Основное окно

Основное окно программы (см. рис. 1) представляет собой аналог проводника в Windows или файлового менеджера Nautilus в Ubuntu.

Рис. 1. Основное окно wxGISCatalog

Основное окно включает в себя строку меню (1), панели инструментов (2), рабочую область (3), дерево элементов каталога (4) и строку состояния (5).

Меню, панели инструментов и контекстные меню могут настраиваться пользователем. Для этого необходимо вызвать специальный диалог (см. рис. 2).

Для вызова диалога необходимо выбрать в меню Tools → Customize... (Инструменты → Настроить...) или вызвать контекстное меню, щелчком по стрелке в конце любой из панелей инструментов и выбрать Customize... (Настроить...).

Диалог «Настроить» включает в себя две вкладки: «Панели & Меню» и «Команды».

Вкладка «Панели & Меню» состоит из списка панелей инструментов и различных меню (1), окна состава команд выбранной панели или меню и кнопок управления составом панелей, меню и команд (3). Список 1 включает в себя следующие категории: меню, контекстные меню, новые меню, панели инструментов.

Категория «Меню» отвечает за состав пунктов меню всего приложения и состав команд в них.

Категория «Контекстные меню» отвечает за состав команд в контекстном меню того или иного элемента каталога (вызывается щелчком правой клавишей мыши на элементе каталога в рабочей области (см. рис. 1 выноска 3) или окне дерева элементов каталога (см. рис. 1 выноска 4) ).

Категория «Новые меню» отвечает за состав команд в подменю «Новый» контекстного меню элемента или меню «Файл».

Категория «Панели инструментов» отвечает за состав команд панелей инструментов.

Вкладка «Команды» включает в себя дерево категорий (4) и окна состава команд выбранной категории (5).

При двойном щелчке мышью по команде в окне 2 или 5 открывается диалог ввода «горячих клавиш» в котором можно ввести необходимую комбинацию.

Следует обратить внимание, что любые изменения в диалоге «Настроить» сразу же применяются.

Для настройки всего приложения служит диалог «Параметры», который может быть вызван при помощи меню Tools → Options (Инструменты → Параметры) или правым щелчком мыши по каталогу в дереве 4 рис. 1. В диалоге «Параметры» можно выбрать:

  1. состав корневых элементов, отображаемых в дереве 4 рис. 1
  2. типы данных, отображаемые в дереве 4 рис. 1 (на данный момент включают в себя: папки, архивы, растры, системы координат, текстовые файлы, файлы MapInfo, файлы разметки /kml, kmz, gml, dxf/, шейп-файлы)
  3. показ расширений у элементов каталога
  4. помнить последний путь в каталоге
  5. показывать скрытые файлы и папки
  6. путь до папки файлов локализации
  7. язык локализации
  8. путь до папки системных файлов (файлов необходимых для работы GDAL, GEOS и PROJ.4)
  9. путь до папки логов
  10. записывать диагностические сообщения GDAL

После ввода параметров, некоторые изменения применяются только после перезагрузки приложения (в основном локализация).

Дерево элементов каталога 4 (см. рис. 1) включает в себя «корневые элементы» следующего состава: «Подключения», «Подключения к БД» и «Подключения к Веб сервисам».

Корневой элемент «Подключения» содержит в себе подключения к папкам операционной системы или сетевым (аналог ярлыков). При первом запуске программа сканирует систему пользователя и автоматически формирует подключения к разделам жесткого диска и сетевым подключениям в операционной системе Windows или к корню диска и домашней папке пользователя в операционной системе Linux. Пользователь может добавлять и удалять подключения и переименовывать их.

Корневой элемент «Подключения к БД» содержит в себе настроенные подключения к базам данных. Само подключение представляет собой файл формата xml. Пароли доступа шифруются в зависимости от настроек пользователя.

Корневой элемент «Подключения к Веб сервисам» содержит в себе настроенные подключения к веб сервисам.

Персональные инструменты
Пространства имён

Варианты
Действия
Статьи
Спецпроекты
Инструменты