Работа с векторными данными в ГИС SAGA

Материал из GIS-Lab
(Различия между версиями)
Перейти к: навигация, поиск
(Заполнение атрибутивной таблицы)
(Заполнение атрибутивной таблицы)
Строка 175: Строка 175:
 
Повторяя ту же последовательность шагов, дополним атрибутивную таблицу векторного точечного слоя. Для введения отметок значений абсолютной высоты создадим поле ''ABS_HEIGHT'' типа <tt>4 byte floating point</tt> (поскольку для точек отметки абсолютных высот представлены в виде десятичных дробей).
 
Повторяя ту же последовательность шагов, дополним атрибутивную таблицу векторного точечного слоя. Для введения отметок значений абсолютной высоты создадим поле ''ABS_HEIGHT'' типа <tt>4 byte floating point</tt> (поскольку для точек отметки абсолютных высот представлены в виде десятичных дробей).
  
<span style="color:red">'''NB'''</span> Заполняя поле, в качестве знака-разделителя используйте <span style="color:red">'''.'''</span> (точку), а не ''',''' <s>запятую</s>.
+
<span style="color:red">'''NB'''</span> Заполняя поле, в качестве знака-разделителя используйте <span style="color:red">'''.'''</span> «точку», а не ''',''' «<s>запятую</s>».
  
 
Для описания типа высотной отметки создадим поле ''POINT_TYPE'' типа <tt>1 byte integer</tt>, присваивая код 0 точкам местности, а 1 – пунктам государственной геодезической сети.
 
Для описания типа высотной отметки создадим поле ''POINT_TYPE'' типа <tt>1 byte integer</tt>, присваивая код 0 точкам местности, а 1 – пунктам государственной геодезической сети.

Версия 19:35, 27 апреля 2013

Эта страница является черновиком статьи.


Описание инструментария SAGA для работы с шейп-файлами на примере векторизации фрагмента топографической карты

Несмотря на аналитическое назначение и направленность на работу с растровыми данными, SAGA содержит необходимый набор инструментов для создания, редактирования и базового анализа шейп-файлов. В качестве подложки для векторизации в данной статье будет использован лист топографический карты М-37-121 в ПСК UTM WGS 84, процедура привязки которого была рассмотрена ранее.

Содержание

Создание и редактирование полигонального векторного слоя

На вкладке Modules двойным щелчком мыши запускаем модуль Shapes – Tools => Create New Shapes Layer. В диалоговом окне модуля задаем имя нового шейп-файла Namearea_plg, а в поле Shape Type из выпадающего списка выбираем Polygon. Прочие параметры (Number of Attributes, Attributes) пока оставляем без изменений и нажимаем Okay. Перейдя на вкладку Data можно видеть, что в списке слоев данных появился новый элемент группы Shapes – полигон area_plg.

Saga vector 01.png
Saga vector 02.png

Пока что этот слой не содержит ни одного элемента и прежде чем приступить к редактированию, его нужно добавить на карту. Для этого двойным щелчком по имени файла в списке слоев запустим диалог и выберем карту, в которую хотим добавить данные. Если все сделано верно, то при переходе на вкладку Maps вы увидите, что карта M-37-121_utm содержит два элемента – растровый слой M-37-121_utm (подложка по которой будет производиться векторизация) и векторный полигональный слой area_plg.

Saga vector 03.png Saga vector 04.png

Для начала редактирования вернитесь на вкладку Data и щелкнув по имени слоя area_plg правой кнопкой мыши из контекстного меню выберите пункт Edit => Add Shape.

Saga vector 05.png

Воспользовавшись инструментами Saga georef zoom.png Zoom и Saga georef pan.png Pan, увеличьте и удобно расположите в окне участок топокарты размером, например, 5×5 квадратов. Определившись с фрагментом для векторизации, на панели инструментов выберите Saga georef action.png Action. Фиксируя узлы по углам (щелчок левой кнопкой мыши), нарисуйте соответствующий квадрат. Для остановки процесса редактирования полигона в последнем узле сделайте также щелчок правой кнопкой мыши.

Saga vector 06.png

В месте правого щелчка появится контекстное меню, в котором нужно убрать галочку рядом с Edit Selected Shape. Когда программа предложит сохранить изменения, согласитесь и нажмите Да. При этом внешний вид нарисованного полигона изменится - он станет непрозрачным.

Saga vector 07.png Saga vector 08.png

Сохраните созданный файл: из контекстного меню area_plg выберите Save As… и укажите путь к папке на диске. Обратите внимание, что созданный векторный файл по умолчанию сохраняется в формате ESRI Shape Files с расширением *.shp.

Saga vector 09.png
Saga vector 10.png

После сохранения файла настроим параметры отображения слоя. Для начала щелчком инструмента Saga georef action.png Action в любом месте за пределами полигона, снимем выделение элемента. В окне свойств объекта (справа) в блоке Display изменим параметр Fill Style на Transparent (это сделает полигон прозрачным внутри), а потом определим свойства границы Outline, установив параметры цвета Color – Red и толщины линии Size – 2. Для применения внесенных изменений нажимаем Apply.

Saga vector 11.png

Создание и редактирование линейного векторного слоя

На вкладке Modules двойным щелчком мыши запускаем модуль Shapes – Tools => Create New Shapes Layer. В диалоговом окне модуля задаем имя нового шейп-файла Namerelief_pln, а в поле Shape Type из выпадающего списка выбираем Lines. Прочие параметры (Number of Attributes, Attributes) оставляем без изменений и нажимаем Okay. Перейдя на вкладку Data можно видеть, что в списке слоев данных появился новый элемент группы Shapes – линия relief_pln.

Saga vector 12.png
Saga vector 13.png

Двойным щелчком добавим новый слой на карту. Перейдя на вкладку Maps убедимся, что карта M-37-121_utm содержит уже три элемента – растровый слой M-37-121_utm, созданный ранее векторный полигональный слой area_plg и новый линейный слой relief_pln.

Saga vector 03.png Saga vector 14.png

Для начала редактирования слоя вернемся на вкладку Data и в контекстном меню слоя relief_pln выберем пункт Edit => Add Shape.

Saga vector 15.png

При помощи инструментов Saga georef zoom.png Zoom и Saga georef pan.png Pan увеличьте и удобно расположите в окне часть рабочего фрагмента топокарты. Определившись с начальной горизонталью, перейдите в режим Saga georef action.png Action и фиксируя узлы в перегибах (левый щелчок мыши) отрисуйте соответствующую линию. Чтобы остановить процесс редактирования в последнем узле сделайте правый щелчок мышью. В месте правого щелчка появится контекстное меню, в котором нужно убрать галочку рядом с Edit Selected Shape. Когда программа предложит сохранить изменения, согласитесь и нажмите Да. Повторяя предыдущие действия, т.е. добавляя новый элемент для каждой изолинии, векторизируйте все горизонтали выбранного фрагмента (и основные, и дополнительные).

Процесс редактирования векторных слоев в SAGA упрощается возможностями:

  • параллельного использования инструментов. Например, в процессе проведения линии может возникнуть необходимость подвинуть карту или увеличить/ уменьшить ее. Для этого не нужно останавливать редактирование – просто выберите необходимый инструмент (Saga georef pan.png Pan, Saga georef zoom.png Zoom или Saga georef fullext.png Zoom To Full Extent). Воспользуйтесь им, чтобы, например, переместить карту, а затем снова нажмите Saga georef action.png Action – курсор автоматически перейдет в режим редактирования в том самом месте, где вы вынуждены были прерваться;
  • повторного редактирования элементов. В том случае, если вы хотите модифицировать фрагмент уже проведенной линии, выделите ее Saga georef action.png Action - протяните курсор по линии, удерживая нажатой левую кнопку мыши, и она подсветится красным цветом. После этого из контекстного меню слоя выберите Edit => Edit Selected Shape.
Saga vector 16.png

Вид выбранной линии изменится таким образом, что станут видимыми узловые точки. Для их редактирования воспользуйтесь Saga georef action.png Action, который в зависимости от объекта наведения, может работать в режимах:

Saga vector 17.png
- выделение узла левым щелчком мыши, изменение его местоположения при движении мыши с нажатой левой кнопкой, удаление Delete'ом с клавиатуры;
Saga vector 18.png
- добавление узловых точек.

Для сохранения внесенных изменений из контекстного меню слоя выберите пункт Edit и снимите галочку с Edit Selected Shape;

  • добавления части объекта. Иногда возникает необходимость создания так называемых составных объектов (multipart fetaures): например, когда горизонталь прерывается или выходит за границы векторизируемого участка и возвращается. В таком случае из пункта редактирования контекстного меню слоя следует выбрать Edit => Add Part.

NB Элемент к которому добавляется часть, должен находиться в режиме редактирования.

Saga vector 19.png

В результате будет создан объект, состоящий из нескольких фрагментов, но ГИС будет воспринимать его как единый элемент шейп-файла, представленный одной строкой атрибутивной таблицы.

  • удаления элементов. Для этого выделите изолинию Saga georef action.png Action и нажмите Delete с клавиатуры.

По окончании редактирования сохраните файл: из контекстного меню relief_pln выберите Save As… и укажите путь к рабочей папке проекта на диске.

Создание и редактирование точечного векторного слоя

На вкладке Modules двойным щелчком мыши запускаем модуль Shapes – Tools => Create New Shapes Layer. В диалоговом окне модуля задаем имя нового шейп-файла Namerelief_pnt, а в поле Shape Type из выпадающего списка выбираем Point. Прочие параметры (Number of Attributes, Attributes) оставляем без изменений и нажимаем Okay. Перейдя на вкладку Data можно видеть, что в списке слоев данных появился новый элемент группы Shapes – точки relief_pnt.

Saga vector 20.png
Saga vector 21.png

Двойным щелчком добавим новый слой на карту. Перейдя на вкладку Maps увидим, что карта M-37-121_utm содержит уже четыре элемента – растровый слой M-37-121_utm, созданные ранее векторные слои area_plg, relief_pln и новый точечный слой relief_pnt.

Saga vector 03.png Saga vector 22.png

Для начала редактирования слоя вернемся во вкладку Data и в контекстном меню слоя relief_pnt выберем пункт Edit => Add Shape.

Saga vector 23.png

При помощи Saga georef zoom.png Zoom и Saga georef pan.png Pan увеличьте и удобно расположите в окне часть рабочего фрагмента топокарты. Определившись с высотной отметкой, Saga georef action.png Action поставьте точку.

NB Если вы не хотите создавать составной объект (multipart feature), после постановки каждой точки необходимо отключать галочку рядом с Edit Selected Shape.

Saga vector 24.png

Таким образом, для корректного представления всех высотных отметок нам необходимо каждый раз добавлять новый элемент. Когда программа предложит сохранить изменения, согласитесь и нажмите Да. По окончании редактирования сохраните файл: из контекстного меню relief_pnt выберите Save As… и укажите путь к рабочей папке проекта на диске.

Заполнение атрибутивной таблицы

Чтобы открыть атрибутивную таблицу слоя, выберите из его контекстного меню пункт Attributes => Show.

Saga vector 25.png
Saga vector 26.png

Внешний вид панели инструментов изменится в соответствии с основными задачами редактирования атрибутивных таблиц:

Saga vector add field.png
- добавить поле;
Saga vector delete fields.png
- удалить поле/я;
Saga vector add record.png
- добавить запись;
Saga vector insert record.png
- вставить запись;
Saga vector delete selected records.png
- удалить выбранные записи;
Saga vector delete all records.png
- удалить все записи.

Первичная структура таблицы задавалась на этапе создания шейп-файла, поэтому сейчас она содержит лишь два поля по умолчанию: служебное поле ID и текстовое NAME. Поскольку мы не планируем вносить информацию в поле NAME, его лучше удалить инструментом Saga vector delete fields.png Delete Fields. В диалоговом окне Delete Fields отмечаем поле, которое хотим удалить (NAME) и нажимаем Okay.

Saga vector 27.png

Для добавления нового поля используем Saga vector add field.png Add Field. В появившемся диалоговом окне прописываем следующие свойства поля: название NameABS_HEIGHT, тип переменной Field Type – 2 byte integer (поскольку потенциально на карте могут встретится значения высоты горизонталей больше 255 м), прочие параметры диалога – Insert Position (поле относительно которого размещается новая колонка) и Insert Method – after (ее местоположение после/ до определенного поля) оставляем без изменений и нажимаем Okay.

Saga vector 28.png

В результате в атрибутивной таблице появится новое поле, в которое мы занесем значения абсолютной высоты для векторизированных горизонталей. Для удобства работы расположим рядом в рабочем окне карту и атрибутивную таблицу – это можно сделать через меню Window => Tile Horizontally / Tile Vertically. В результате при выделении строки таблицы мы одновременно будем видеть соответствующую горизонталь, что облегчит процесс ввода значений.

Saga vector 29.png
Saga vector 30.png

Чтобы добавить к атрибутивной таблице информацию про тип изолиний, снова воспользуемся Saga vector add field.png Add Field. В появившемся диалоге введем следующие значения: название NameLINE_TYPE, тип переменной Field Type – 1 byte integer (будем вводить простые числовые коды), прочие параметры диалога – Insert Position (поле относительно которого размещается новая колонка) и Insert Method – after (ее местоположение после/ до определенного поля) оставляем без изменений и нажимаем Okay. Теперь в новое поле LINE_TYPE введем значения-коды, описывающие тип горизонтали – 0 (вспомогательная), 1 (основная), 2 (утолщенная). По окончании, атрибутивная таблица будет иметь примерно следующий вид:

Saga vector 31.png

Повторяя ту же последовательность шагов, дополним атрибутивную таблицу векторного точечного слоя. Для введения отметок значений абсолютной высоты создадим поле ABS_HEIGHT типа 4 byte floating point (поскольку для точек отметки абсолютных высот представлены в виде десятичных дробей).

NB Заполняя поле, в качестве знака-разделителя используйте . «точку», а не , «запятую».

Для описания типа высотной отметки создадим поле POINT_TYPE типа 1 byte integer, присваивая код 0 точкам местности, а 1 – пунктам государственной геодезической сети.

Расчет пространственных характеристик объектов

Как и большинство современных ГИС SAGA дает возможность автоматически рассчитывать пространственные характеристики для объектов векторных слоев при условии, что они находятся в спроецированной СК. В нашем случае проекция для создаваемых векторных слоев не прописывалась индивидуально, но мы знаем, что создавались они на основе растрового слоя в ПСК UTM, т.е. в них по умолчанию заложена проекция растровой подложки и результаты расчетов будут представлены в единицах измерения используемой ПСК (м и м2). Однако не следует забывать, что если мы планируем работать с этими данными в дальнейшем, в другом ПО ГИС, информацию об используемой СК следует присвоить с помощью модуля Projection – Proj.4 => Set Coordinate Reference System. О том, как это сделать, рассказано в предыдущей статье.

Для расчета пространственных характеристик полигонального слоя выберите модуль Shapes – Polygons => Polygons Properties[1]. В диалоговом окне в качестве обрабатываемого слоя укажите area_plg. Строку <Polygons with Property Attributes можно оставить без изменений, чтобы сразу добавить результаты в атрибутивную таблицу слоя.

Saga vector 36.png

После появления сообщения Module execution succeeded, откроем атрибутивную таблицу слоя, в которой появятся два новых поля:

Saga vector 37.png

Зная, что линии километровой сетки на карте проведены через каждые 2 000 м, а размер нашего полигона задавался участком 5×5 квадратов, несложно проверить результат. При одной стороне полигона в 10 000 м (10 км) его периметр будет 40 000 м (40 км), а площадь – 100 000 000 м2 (100 км2). Как видим, рассчитанные по векторному слою значения близки к приведенным. Незначительные расхождения объясняются тем, что границы территории по карте проводились «на глаз», а не фиксировались по точкам с четко определенными координатами.

  1. Аналогичным образом пространственные характеристики могут быть рассчитаны и для полилинейного шейп-файла с помощью модуля Shapes – Lines => Lines Properties (длина линий, количество узлов и сегментов между ними). Геометрические характеристики точечного слоя не рассчитываются, но для добавления координат точек можно воспользоваться модулем Shapes – Points => Add coordinates to points.

Настройка параметров отображения слоев в соответствии с атрибутивными данными

Персональные инструменты
Пространства имён

Варианты
Действия
Статьи
Спецпроекты
Инструменты